How to solve the error“The ECM is not supported”for 2019C CAT Caterpillar ET Diagnostic Adapter III?

If you use the CAT Caterpillar ET Diagnostic Adapter III of the 2019C version of the software to test some older CAT cars, the following prompt appears:
23

Caterpillar ET 2019C (replaces CAT ET 2018b, 2019A,2019B) Electronic Technician Diagnostic Software :
Brand: Caterpillar
Region: WorldWide
Support Multi-language :English, Chinese, Danish, French, German, Italian, Japanese, Portuguese, Russian, Spanish
Publication date: 10.2019 year
Support All cars of CAT
This ECU is not supported.Please ensure that the latest version of the service tool is installed.and that the current subscription allows serviceing of this ECU.

It may be that the 2019C version of the software does not support this model. Please use the 2015A version of the software.

In our CAT Caterpillar ET Diagnostic Adapter III equipment, we will configure both 2015A and 2019C versions of the software. New models can use the 2019C software, and older models may need to use the 2015A software.

Be the first to comment

Leave a Reply

Your email address will not be published.

*