Tag Archive: MB SD Connect C4

Clone Xentry Connect C5- Good & Bad Things

I bought “Original Clone Xentry Connect C5” from China’s retail store in 2017/12.

Good thing:

1. Unlike bad products of mercedes diagnostic tool C5 type C4 motherboard, texture is good
2. DoIP specification

Bad thing:

1. Because it is VM system + 32bit, the reaction is slow (SSD though …)
2. Vediamo can be used, but feeling like driving with DELL D 630 (unsuitable)
3. The DTS Monaco software is installed but the connection with the vehicle is NG (currently retail stores and manufacturer engineers are thinking about how to fix it)
4. Passwords are applied to each drive, making it hard to customize
5. Retail shops and manufacturer engineers lack knowledge (take time to support)

My thoughts

I think purchasing this product is still early.

There are too many trouble elements.

I’ll report it when the situation changes.

What I currently use (stable and comfortable)

New car: eCom (64 bit)
Normal: Clone SDConnect C4 (64 bit)
Old car: Star C3

Best regards

MB SD C4 Tourismo bus communication error (fixed)

I bought the MB SD C4+Dell D630 Laptop pre-installed bundle, when I test it have the problem Mb Star C4 cannot power on when connected with Mercedes Tourismo bus, I contacted there customer service at cnautotool.com, and here is the solution provided by their engineer.

I will explain my problem in detail:

” I have tried 2 different mb sd connect c4 on Tourismo buses and sd connect does not power on.In the meantime those MB SD Connect C4 works normally to any other MB Truck and car.also on Tourismo have check MB Star C3 and works normally.”

You should check:

bus with OBD
pin 4 + 5
both must be connected and ground

In SDConnect “-” is 5 pin only. There is 4 contact not used in 16pin OBD connector.

“i’m getting an communication error when connecting xentry to a Mercedes tourismo.”


A Communication error has occurred when access FPS system


– turn OFF/ON BUS ground switch (our remove battery – cable). FPS1 wake up and MB Star diagnostic recognized FPS1/VIN code.


– enter the DAS ATEGO truck come and place manually and then it will work perfect

” Another problem is : “Currently the speed limit is set to 100 km/h. I’m trying to set it to higher value (with Mercedes Star Diagnosis MB SD C4 DAS using modified EOL files). On the menu it tells me that I can, because there are higher values (105 km/h. 112 km/h, etc). But when I try to set the speed limit to higher than 100 km/h it doesn’t allow me to do it (can’t save the changes). When I try to set it below 100 km/h everything goes fine.”

I done the Access special settings , and it working perfect now!